Add the Sailthru Mobile SDK into your apps to enable tracking of live user data, user activity, and send push and in-app messages. It typically takes less than 10 minutes to successfully integrate.

Pick a platform below for integration documentation:

iOSv7.3.1
Released 2018-06-24
Androidv5.7.1
Released 2018-06-19
Cordovav4.0.3
Released 2017-12-06
Unityv1.0.0
Released 2017-12-06
React Nativev1.0.0
Released 2017-12-06

📘

Note

The above guides assume you are a developer and have already gone through the process of creating an app in the platform.

Migrating from another platform

We can help you migrate existing push tokens and data from your current provider. Please read Migrating to Sailthru Mobile guide for more details.

Message Stream Templates

Our Message Stream Templates are available for Native iOS and Android apps only.

🚧

Plugin SDKs limitations

Our SDKs for Unity and React Native experience don't allow to customize the look and feel of in-app notifications. This is due to the nature of their plugin system architecture. We hope to bring customization to these platforms in the near future.

Because of the nature of Cordova, Unity, React Native and their (many!) variants, some integrations may take longer. We're of course happy to help during this time. Reach out to support for assistance.

Deprecation and Support Policy

Our SDKs follow Semantic Versioning (SemVer). We use SemVer to communicate the significance of change between SDK versions to you. We also use deprecation annotations to mark deprecated methods, which you can expect to be removed fully in the following major release. If you are using a deprecated method, we encourage you to use the supported alternative. For each deprecated method, we provide a supported alternative, either in the form of another method or as a different solution.

We support the latest major release only with bug fixes. While we will keep a public facing repository of past SDK version for reference, we will not update nor support them. Customers who implement a version of the SDK other than the latest may do so at their own risk, understanding that any known or unknown issue may not be addressed, in particular if a newer SDK version contains a resolution for such issues.

As always, keeping up to date by using the latest version of the Sailthru Mobile SDKs is recommended. You can read the release notes which include details about bug fixes and new features, and these are attached to our GitHub releases. It is also advised you update to the latest SDK version before contacting support.

This also applies to our open source wrapper SDKs for Cordova, React Native and Unity. These wrappers are maintained by both the open source community and Carnival, and are reviewed quarterly for updates and maintenance.

As always, we’re more than happy to help with any questions you have while developing with our SDKs. Don’t hesitate to reach out to your Customer Success Manager (CSM) or our Support team if you have questions during development.

Supported OS and Tooling Versions

SDK

iOS

Android

Cordova

React Native

Unity

Type

Core

Core

Wrapper

Wrapper

Wrapper

Supported OS Versions

iOS 8.0+

Android Ice Cream Sandwich 4.0+ (API Level 14)

Same as Core

Same as Core

Same as Core

Supported Tooling Versions

Xcode 8+

Android Studio 3+

Cordova 6.0+

React Native 0.48+

Unity 5+ (2017.2.x)